HDU 1005 ( Number Sequence )

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/82081792
                                    Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 202775 Accepted Submission(s): 51077

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

#include<iostream>
#include"string.h"
using namespace std;
long int a,b,n,i,c[1000],num=0,j,m=0;
int main()
{
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0)
            break;
        memset(c,-1,sizeof(long int)*1000);
        c[1]=1;
        c[2]=1; 
        if(n==1||n==2)
            cout<<'1'<<endl;
        else
        {
            for(i=3;i<1000;i++)
            {
                c[i]=(a*c[i-1]+b*c[i-2])%7;
            }
            for(i=1;i<100;i++)
            {
                for(j=3;j<100;j++)
                {
                    if(c[j]==c[j+i]&&c[j+i]==c[j+2*i])
                    {
                        continue;
                    }
                    else
                    {
                        m=1;
                        break;
                    }
                }
                if(m==0)
                {
                    num=i;
                    break;
                }
                m=0; 
            }
            cout<<c[3+(n-3)%num]<<endl;
        }
        m=0;
        num=0;
    }
} 

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/82081792