Hdu.1005.Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 196614    Accepted Submission(s): 49257


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
  
1 1 3 1 2 10 0 0 0
 

Sample Output
 
  
2 5
 

Author
CHEN, Shunbao
 

Source

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
    int A,B,n;
    while(cin>>A>>B>>n&&(A+B+n)){
        long long a[210]={0,1,1};
        int i,flag=0;
        for(i=3;i<=200;i++){
            a[i]=(A*a[i-1]+B*a[i-2])%7;
            if(a[i]==1&&a[i-1]==1) break;
            if(a[i]==0&&a[i-1]==0) {flag=1;break;}
        }
        if(flag) cout<<0<<endl;
        else printf("%lld\n",n%(i-2)?a[n%(i-2)]:a[i-2]);
    }
}



猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/80427181