HDU1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 200250    Accepted Submission(s): 50305


 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

一开始以为避开递归的坑就行了,没想到Memory Limit Exceeded了。

原代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<iomanip>
#include<cmath>
int F[100000001];
using namespace std;
int main()
{   
	int A,B,n,i;
	F[1]=1;F[2]=1;
	while(cin>>A>>B>>n&&A!=0&&B!=0&&n!=0)
	{
		for(i=3;i<=n;i++)
		F[i]=(A*F[i-1]+B*F[i-2])%7;
		cout<<F[n]<<endl;
	}
}

查了一下,说是48一个循环。可能是因为玄学。以后再去深究吧。

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<iomanip>
#include<cmath>
int F[48];
using namespace std;
int main()
{   
	int A,B,n,i;
	F[1]=1;F[2]=1;
	while(cin>>A>>B>>n&&A!=0&&B!=0&&n!=0)
	{
		for(i=3;i<=47;i++)
		F[i]=(A*F[i-1]+B*F[i-2])%7;
		cout<<F[n%48]<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40889820/article/details/81274531