HDU 1005 :Number Sequence(规律打表)

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

#include<cstring>
#include <iostream>  
#include <cstdio>
using namespace std;  
int main()
{
    int a,b,n,array[48];
    array[1]=1;array[2]=1;
    while(scanf("%d %d %d",&a,&b,&n)&&(a||b||n))
    {
        for(int i=3;i<48;i++)
            array[i]=((a*array[i-1]+b*array[i-2])%7);
        cout<<array[n%48]<<endl;
    }
    return 0;
}
发布了94 篇原创文章 · 获赞 29 · 访问量 8577

猜你喜欢

转载自blog.csdn.net/m0_43382549/article/details/97035155
今日推荐