hdu 1005Number Sequence

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34195441/article/details/53148384

Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5

数学

#include<stdio.h>
int main()
{
    int a,b,n,i;
    int f[1009];
    while(scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
    {
        f[1]=1;
        f[2]=1;
        for(i=3;i<=1008;i++)
            f[i]=(a*f[i-1]+b*f[i-2])%7;
        printf("%d\n",f[(n-1)%1008+1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34195441/article/details/53148384