HDU ACM1005——Number Sequence

Number Sequence

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

这是一道找规律的题目,n这么大不可能用循环一个个算出来,因为结果要mod 7,所以结果必然会形成循环,找出这个周期即可。

#include<stdio.h>
#include<math.h>
int main()
{
    int A,B,n,i;
    int f[55];
    while(scanf("%d %d %d",&A,&B,&n)!=EOF){
        if(A==0 && B==0 && n==0)break;
        f[1]=f[2]=1;
        for(i=3;i<=48;i++)  //周期为48,f[1]=f[49],f[2]=f[50] 
            f[i] = ((A * f[i-1] + B * f[i-2]) % 7);
        n=n%48; 
        f[0]=f[48];
        printf("%d\n",f[n]);
    }
    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/BarisGuo/article/details/82048363