hdu1005 Number Sequence KMP

Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

思路:

KMP板子题

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = (int)1e6 + 10;
const int MAXN = (int)1e4 + 10;
int f[maxn];
int s[MAXN];
int nxt[MAXN];
int n,m;
void init(int m)
{
	int i = 1,j = 0;
	nxt[0] = 0;
	while (i < m)
	{
		if (s[i] == s[j])
			nxt[i ++] = ++ j;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
	}
}
int kmp()
{
	int i = 0,j = 0;
	while (i < n && j < m)
	{
		if (f[i] == s[j])
		{
			i ++;
			j ++;
		}
		else if (!j)
		{
			i ++;
		}
		else
		{
			j = nxt[j - 1];
		}
	}
	if (j == m)
		return i - m + 1;
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while (t --)
	{
		memset(nxt,0,sizeof(nxt));
		scanf("%d %d",&n,&m);
		for (int i = 0;i < n;i ++)
			scanf("%d",&f[i]);
		for (int i = 0;i < m;i ++)
			scanf("%d",&s[i]);
		init(m);
		printf("%d\n",kmp());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81814231