HDU1005 Number Sequence(找规律,周期是变化的)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 198316    Accepted Submission(s): 49744


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
 
Author
CHEN, Shunbao
 
Source
 
题目意思:
输入a,b,n
根据a,b确定表达式,根据表达式确定f(n)
f(n)=(a*f(n-1)+b*f(n-2))%7
分析:
n太大了,不能递归,也不能打表
只能找规律
确定循环周期就好办了
记住循环周期随着输入是变化的
code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int a,b,n;
    int f[10000];
    f[1]=1;
    f[2]=1;
    while(~scanf("%d %d %d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0)
            break;
        int i;
        for(i=3;i<10000;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==f[1]&&f[i-1]==1)//两个连续的1出现,表面循环到了一个周期的结束
                break;
        }
        n=n%(i-2);//周期为i-2
        f[0]=f[i-2];//周期结束的那个
        printf("%d\n",f[n]);
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9295863.html
今日推荐