PAT(Advanced Level) 1002. A+B for Polynomials (25)

太长时间没有写代码了,看到这个题居然还有点儿懵逼。后来想了一下,数组来表示多项式系数轻而易举就解决了。不过还是有点儿坑,有几点要注意一下,不然始终不能全对。

1.最开始居然开了三个数组来做,写完了代码才突然想到根本没必要,简直浪费空间。

2.一定要考虑多项式A和B的均没有相同的系数,所以数组要开到大小1001不够,要开到2001,不然过不了测试点1。

3.注意一下精确到0.1的小数输出的函数。

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

#include<iostream>
#include<cstdlib>
#include <iomanip>
using namespace std;
int main(void)
{
	int A_Exponent, B_Exponent,SUM_Exponent=0;
	double SUM_P[2001] = { 0 };//数组存储多项式的系数
	cin >> A_Exponent;
	for (int i = 0; i < A_Exponent; i++)
	{
	int exponent;double coefficient;
	cin >> exponent;
	cin >> coefficient;
	SUM_P[exponent] = coefficient;
	}
	cin >> B_Exponent;
	for (int i = 0; i < B_Exponent; i++)
	{
		int exponent; double coefficient;
		cin >> exponent;
		cin >> coefficient;
		SUM_P[exponent]+= coefficient;
	}
	for (int i = 1999; i >= 0; i--)
		if (SUM_P[i])
			SUM_Exponent++;
	cout << SUM_Exponent;
	for (int i =1999; i>=0; i--)
		if (SUM_P[i])
			cout << " " << i << " " << fixed << setprecision(1) << SUM_P[i];
	system("PAUSE");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/coderwait/article/details/79646054