PAT Advanced 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

多项式相加。开辟float数组,以指数为索引存储系数。遍历统计非零系数个数并输出,输出时注意格式。
#include <bits/stdc++.h>

using namespace std;
float ans[2010],src1[2010],src2[2010];
int main()
{
    int K,tn;
    float an;
    cin>>K;
    for(int i=0;i<K;i++)
    {
        cin>>tn>>an;
        ans[tn]=an;
    }
    cin>>K;
    for(int i=0;i<K;i++)
    {
        cin>>tn>>an;
        ans[tn]+=an;
    }
    int cnt=0;
    for(int i=0;i<2010;i++)
    {
        if(ans[i]!=0)
            cnt++;
    }
    cout<<cnt;
    for(int i=2009;i>=0;i--)
        if(ans[i]!=0)
        {
            cout<<' '<<i<<' ';
            cout<<fixed<<setprecision(1)<<ans[i];
        }

    cout<<endl;
    return 0;
}


猜你喜欢

转载自www.cnblogs.com/zest3k/p/11443913.html