PAT Advanced level 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 2 1.5 1 2.9 0 3.2




模拟多项式加法
模拟就行了……
想到什么再补吧(

#include<iostream>
#include<cstdio>
#include<algorithm>
double a[1001];
using namespace std;

int main(){
    int k1;scanf("%d",&k1);
    for(int i=1;i<=k1;++i){
        int ni;double ai;
        scanf("%d%lf",&ni,&ai);
        a[ni]+=ai; 
    }
    int k2;scanf("%d",&k2);
    for(int i=1;i<=k2;++i){
        int ni;double ai;
        scanf("%d%lf",&ni,&ai);
        a[ni]+=ai; 
    }
    int cnt=0;
    for(int i=1000;i>=0;--i){
        if(a[i])++cnt;
    }
    printf("%d",cnt);
    for(int i=1000;i>=0;--i){
        if(a[i])printf(" %d %.1f",i,a[i]);
    }
    return 0;
} 

猜你喜欢

转载自www.cnblogs.com/wypx/p/12188391.html