PAT (Advanced Level) Practice 1004 Counting Leaves (30 分)树的层次遍历

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=105;
int n,m;
int par[maxn];
int vis[maxn];
int root;
vector<int>v[maxn],ans;
void traverse(int x)
{
    queue<int>q;
    q.push(x);
    while (!q.empty())
    {
        int Size=q.size();
        int num=0;
        while (Size--)
        {
            int t=q.front();
            q.pop();
            if(!v[t].size())
            {
                num++;
            }
            else
            {
                for (int i=0;i<v[t].size();i++)
                {
                    q.push(v[t][i]);
                }
            }
        }
        ans.push_back(num);
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    memset (par,-1,sizeof(par));
    memset (vis,0,sizeof(vis));
    for (int i=0;i<m;i++)
    {
        int x;
        scanf("%d",&x);
        vis[x]=1;
        int k;
        scanf("%d",&k);
        for (int i=0;i<k;i++)
        {
            int y;
            scanf("%d",&y);
            vis[y]=1;
            v[x].push_back(y);
            par[y]=x;
        }
    }
    for (int i=0;i<maxn;i++)
    {
        if(par[i]==-1&&vis[i])
        {
            root=i;
            break;
        }
    }
    traverse(root);
    for (int i=0;i<ans.size();i++)
    {
        printf("%d%c",ans[i],i==ans.size()-1?'\n':' ');
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/84328839