PAT (Advanced Level) Practice 1030(Dijkstra + DFS)

1030 Travel Plan (30 分)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

分析:这里用Dijkstra + DFS来解决问题。Dijkstra仅用来求最短路径,用一个二维vector来储存所有最短路径,之后通过DFS来遍历所有最短路径来求出符合要求的第二标尺。

代码:

#include<iostream>
#include<algorithm>
#include<vector>
#define MAXN 501
#define INF 0x3fffffff
using namespace std;
int G[MAXN][MAXN];
int d[MAXN];
int C[MAXN][MAXN];
int visit[MAXN] = { 0 };
vector<int> pre[MAXN];
vector<int> path, tempPath;
int N, M, C1, C2;
int minCost = INF;
int num[MAXN];
void dfs(int v) {
	tempPath.push_back(v);
	if (v == C1) {
		int cost = 0;
		for (int i = tempPath.size() - 1; i > 0; i--) {
			int index = tempPath[i];
			int indexNext = tempPath[i - 1];
			cost += C[index][indexNext];
		}
		if (cost < minCost) {
			minCost = cost;
			path = tempPath;
		}
	}
	for (int i = 0; i < pre[v].size(); i++) {
		dfs(pre[v][i]);
	}
	tempPath.pop_back();
}
void dijkstra(int start) {
	d[start] = 0;
	for (int i = 0; i < N; i++) {
		int u = -1, minN = INF;
		for (int j = 0; j < N; j++) {
			if (visit[j] == 0 && d[j] < minN) {
				u = j;
				minN = d[j];
			}
		}
		if (u == -1) {
			return;
		}
		visit[u] = 1;
		for (int v = 0; v < N; v++) {
			if (d[v] > d[u] + G[u][v]) {
				d[v] = d[u] + G[u][v];
				pre[v].clear();
				pre[v].push_back(u);
			}else if (d[v] == d[u] + G[u][v]) {
				pre[v].push_back(u);
			}
		}
	}
}
int main() {
	fill(G[0], G[0] + MAXN * MAXN, INF);
	fill(d, d + MAXN, INF);
	cin >> N >> M >> C1 >> C2;
	for (int i = 0; i < M; i++) {
		int u, v, w, cost;
		cin >> u >> v >> w >> cost;
		G[u][v] = G[v][u] = w;
		C[u][v] = C[v][u] = cost;
	}
	dijkstra(C1);
	dfs(C2);
	for (int i = path.size() - 1; i >= 0; i--) {
			cout << path[i] << ' ';
	}
	cout << d[C2] << ' ' << minCost << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82749200