HDU 1312 Red and Black(简单BFS 联通块)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26972    Accepted Submission(s): 16265


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

Sample Output

 

45 59 6 13

 

Source

Asia 2004, Ehime (Japan), Japan Domestic

 

Recommend

Eddy

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define maxn 1005
using namespace std;
struct node{
    int x,y;
    node(){}
    node(int x,int y):x(x),y(y){}
    };
int sx,sy;
int vis[maxn][maxn];
char mp[maxn][maxn];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int n,m;
int bfs()
{memset(vis,0,sizeof(vis));
queue<node>q;
while(!q.empty())
    q.pop();
 q.push(node(sx,sy));
vis[sx][sy]=1;

    node u;
    int sum=1;
    while(!q.empty())
 {

  u=q.front();
    q.pop();

for(int i=0;i<4;i++)
{
    int xx=u.x+dx[i];
    int yy=u.y+dy[i];

    if(!vis[xx][yy]&&xx>=1&&xx<=n&&yy>=1&&yy<=m&&mp[xx][yy]=='.')
    {
        q.push(node(xx,yy));
        vis[xx][yy]=1;
        sum++;

    }
}
 }
return sum;

}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {if(m==0&&n==0)
    break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            scanf(" %c",&mp[i][j]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            if(mp[i][j]=='@')
        {
            sx=i;
            sy=j;
        }

        printf("%d\n",bfs());
    }
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84401972