BFS求联通块——Red and Black (HDU 1312)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........

Sample Output

45
59
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int vis[25][25],n,m;
char maze[25][25];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
    int x,y;
}s;
void bfs() //DFS求联通块,只要将能走到的位置标记,最后统计即可
{
    queue<node> que;
    que.push(s);
    vis[s.x][s.y] = 1;
    node temp,next;
    while(!que.empty())
    {
        temp = que.front();
        //cout<<temp.x <<" "<<temp.y<<endl;
        que.pop();
        for(int i = 0; i < 4; i++)
        {
            next = temp;
            next.x = temp.x + dir[i][0];
            next.y = temp.y + dir[i][1];
            if(!vis[next.x][next.y] && maze[next.x][next.y] == '.'&& next.x >= 0 && next.y >= 0 && next.x < m && next.y < n)
            {
                vis[next.x][next.y] = 1;
                que.push(next);
            }
        }
    }
}
int main()
{
    while(scanf("%d %d",&n,&m),n+m )
    {
        memset(vis,0,sizeof vis);
        for(int i = 0; i < m; i++)
        {
            scanf("%s",maze[i]);
            for(int j = 0; j < n; j++)
                if(maze[i][j] == '@')
                    s.x = i,s.y = j;
        }
        bfs();
        int sum = 0; //统计走过哪些块
        for(int i = 0; i < m; i++)
            for(int j = 0; j < n; j++)
                if(vis[i][j])
                    sum++;
        cout<<sum<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/88880705