HDU-1312-Red and Black(dfs)

Red and Black


Problem Description:
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
Input:
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
Output:
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
Sample Input:
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output:
45
59
6

13

题意描述:

首先找到@点的坐标,然后往各个能走的地方搜索,每搜索一步记录一下步数,并把走过的点标记。

程序代码:

#include<stdio.h>
void dfs(int x,int y);
char a[25][25];
int m,n,count;
int main()
{
	int i,j,x,y,step;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		count=0;
		if(m==0&&n==0)
			break;
		for(i=0;i<m;i++)
			for(j=0;j<n;j++)
			{
				scanf(" %c",&a[i][j]);
				if(a[i][j]=='@')
				{
					x=i;
					y=j;
				}
			}
		dfs(x,y);	
		printf("%d\n",count);
	}
	return 0;
}
void dfs(int x,int y)
{
	int tx,ty,k;
	int next[4][2]={0,1, 0,-1, 1,0, -1,0};
	if(x<0||x>=m||y<0||y>=n||a[x][y]=='#')
		return;
	count++;
	a[x][y]='#';
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		dfs(tx,ty);
	}
	return;
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81062764