HDU-1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25575    Accepted Submission(s): 15435


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output

 

45 59 6 13

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int m,n,ans;
int f[4][2]={{1,0},{0,-1},{-1,0},{0,1}};
int cnt[25][25];
char str[25][25];

void dfs(int x,int y){
    cnt[x][y]=1;
    for(int i=0;i<4;i++){
        int t=x+f[i][0];
        int p=y+f[i][1];
        if((t>=0&&t<m)&&(p>=0&&p<n)&&(str[t][p]=='.')&&(cnt[t][p]==0)){
            cnt[t][p]=1;
            ans++;dfs(t,p);
        }
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(m==0&&n==0)
            break;
        for(int i=0;i<m;i++){
            scanf("%s",str[i]);
        }
        memset(cnt,0,sizeof(cnt));
        ans=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                if(str[i][j]=='@'){
                    ans++;dfs(i,j);
                }
            }
        }
        printf("%d\n",ans);
    }
return 0;
}

猜你喜欢

转载自blog.csdn.net/yimo_180227/article/details/81325359