Red and Black HDU - 1312 (DFS)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

板子题

BFS,DFS都可

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 30
char map[MAXN][MAXN];
int vis[MAXN][MAXN];
int ans;
int w,h;
int d[4][2]={1,0,-1,0,0,1,0,-1};
void DFS(int x,int y){
	int dx,dy;
	
	vis[x][y]=1;
	for(int i=0 ; i<4 ; i++){
		dx=x+d[i][0];
		dy=y+d[i][1];
		if(dx>=0 && dx<h && dy>=0 && dy<w && !vis[dx][dy] && map[dx][dy]!='#'){
			ans++;
			DFS(dx,dy);
		}
	}
}
int main()
{
	int x,y;
	while(~scanf("%d %d",&w,&h) && (w+h))
	{
		ans=1;
		memset(vis,0,sizeof(vis));
		for(int i=0 ; i<h ; i++)	scanf("%s",map[i]);
		for(int i=0 ; i<h ; i++)
			for(int j=0 ; j<w ; j++)
				if(map[i][j]=='@'){	
					x=i;y=j;
					break;
				}
		DFS(x,y);
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/l_i_n_q_i_n_g/article/details/81365288