HDU1312:Red and Black(DFS)

版权声明:本文为博主原创文章,未经博主同意不得转载。

https://blog.csdn.net/u012325397/article/details/26818317

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
 
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
 
   
45 59 6 13
DFS水题,带来了久违一次AC。太感动了~
#include<stdio.h>
#include<string.h>
char map[25][25];
int vis[25][25],cnt,w,h;

void dfs(int x,int y)
{
	if(x<0||y<0||x>=w||y>=h)
		return ;
	if(map[y][x]=='#')
		return ;
	if(vis[y][x])
		return;
	if(!vis[y][x]&&(map[y][x]=='.'||map[y][x]=='@'))
	{
		vis[y][x]=1;
		cnt++;
	}
	dfs(x+1,y);
	dfs(x-1,y);
	dfs(x,y+1);
	dfs(x,y-1);
}
int main()
{
	int x,y;
	while (scanf("%d%d",&w,&h),w&&h)
	{
		getchar();
		for(int i=0;i<h;++i)
		{
			for(int j=0;j<w;++j)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					x=j;y=i;
				}
			}
				getchar();
		}
		memset(vis,0,sizeof(vis));
		cnt=0;
		dfs(x,y);
		printf("%d\n",cnt);
	}
	return 0;
}


猜你喜欢

转载自www.cnblogs.com/xfgnongmin/p/10799653.html