HDU 1312 Red and Black 【DFS+模板】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

思路:玩家从‘@’开始出发,遇到’#‘走不了,遇到’.’能继续走,问能经过整张图的多少个点(包括该玩家的起始的位置)。代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int n,m,step,x1,y1;     // step用于记录步数 
char map[30][30];  
int vis[30][30];  //标记数组 
int dir[4][2]={1,0,-1,0,0,1,0,-1};  //方向数组 
void DFS(int x,int y)
{   
	if(x<0||x>=n||y<0||y>=m||map[x][y]=='#'||vis[x][y]) //设置递归出口
	  return;
	else
	{
		step++;  //一旦执行else语句,所走步数就会+1 
		for(int i=0;i<4;i++)  
		{
			vis[x][y]=1;
			x1=x+dir[i][0];
			y1=y+dir[i][1];
			DFS(x1,y1);
		}
	 } 
 } 
int main()
{
	while(cin>>m>>n&&n&&m)
	{   
	   step=0;
		memset(vis,0,sizeof(vis));
		memset(map,0,sizeof(map));
		for(int i=0;i<n;i++)
		  cin>>map[i];
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					DFS(i,j);
					//break;
				}
			}
		}
		cout<<step<<endl;
	}
	return 0;
}

ps:你喜欢大海,而哦喜欢你!

猜你喜欢

转载自blog.csdn.net/LOOKQAQ/article/details/81367101