hdu 1312 Red and Black(dfs)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Void_worker/article/details/82431579

题目:
Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26236 Accepted Submission(s): 15854

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1312

代码:

#include<fstream>
#include<iostream>
using namespace std;
const int maxn = 30;
char G[maxn][maxn];
bool vis[maxn][maxn];
int w, h, cnt;
int dir[4][2] = {{0, -1}, {1, 0}, {0, 1}, {-1, 0}};

void dfs(int r, int c){

    for (int i = 0; i < 4; ++i){
        int xx = r + dir[i][0], yy = c + dir[i][1];
        if (xx < 0 || yy < 0 || xx >= h || yy >= w) continue;
        if (!vis[xx][yy] && G[xx][yy] == '.'){
            vis[xx][yy] = true;
            cnt++;
            dfs(xx, yy);
        }
    }
}

int main(){
//    freopen("a.txt", "r", stdin);
    char c;
    while (scanf("%d %d", &w, &h) != EOF && w != 0){
        c = getchar();
        cnt = 0;
        memset(vis, 0, sizeof(vis));
        for (int i = 0; i < h; ++i){
            scanf("%s", G[i]);
        }
        for (int i = 0; i < h; ++i){
            for (int j = 0; j < w; ++j){
                if(G[i][j] == '@'){
                    vis[i][j] = true;
                    cnt++;
                    dfs(i, j);
                }
            }
        }
        cout << cnt << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Void_worker/article/details/82431579