HDU - 1312 Red and Black (广搜求块数)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string.h>
#include<queue>
using namespace std;
int N,M;
char map[21][21];
int vis[21][21];
int moveto[4][2]={0,1,1,0,0,-1,-1,0};
int ans=1;

struct node{
int x;
int y;
}Node;

void bfs(int x,int y)
{
  Node.x=x;
  Node.y=y;
  queue<node>q;
  q.push(Node);
   vis[x][y]=1;
   while(!q.empty())
   {
       node top=q.front();
       q.pop();
       for(int k=0;k<4;k++)
       {
           int newx=top.x+moveto[k][0];
           int newy=top.y+moveto[k][1];
           if(map[newx][newy]=='.'&&newx>=0&&newx<M&&newy>=0&&newy<N&&!vis[newx][newy])
           {
               Node.x=newx;
               Node.y=newy;
               q.push(Node);
               vis[newx][newy]=1;
               ans++;
           }
       }
   }
}
int main(){
    while(~scanf("%d %d",&N,&M)&&N&&M)
    {
       getchar();
       ans=1;
       memset(vis,0,sizeof(vis));
       for(int i=0;i<M;i++)
       {
           scanf("%s",&map[i]);
       }
       for(int i=0;i<M;i++)
       {
           for(int j=0;j<N;j++)
           {
               if(map[i][j]=='@')
               {
                  int startx=i;
                  int starty=j;
                  bfs(startx,starty);
               }
           }
       }
       printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/81670735