hdu1312-Red and Black(深度搜索)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1312

题目原文:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28431    Accepted Submission(s): 17195


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

 

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

 

Sample Output

 

45

59

6

13

题目大意:

        给出一个地图,‘.’代表黑个块,‘#’代表红色块,‘@’代表当前位置,能向四个方向移动,问能到达的方块数。(@也代表一个黑色块)。

解题思路:

        深度搜索DFS

AC代码:

#include <cstdio>
#include <memory.h>
using namespace std;

const int N = 25;
const char BLACK = '.';
const char RED = '#';
const char LOCATION = '@';
const int dx[4] = {0, 1, -1, 0};
const int dy[4] = {1, 0, 0, -1};

char g_map[N][N];

void init()
{
	memset(g_map, '#', sizeof(g_map));
}

int dfs(char mp[][N], const int &row, const int &col, int x, int y)
{
	if (mp[x][y] == RED) return 0;
	mp[x][y] = RED;
	int cnt = 1;
	int i;
	for (i = 0; i < 4; i++)
	{
		cnt += dfs(mp, row, col, x + dx[i], y + dy[i]);
	}
	return cnt;
}

int main()
{
	int m, n;
	while (scanf("%d%d", &n, &m), n || m)
	{
		init();
		int i, j, x, y;
		for (i = 1; i <= m; i++)
		{
			for (j = 1; j <= n; j++)
			{
				scanf(" %1c", &g_map[i][j]);
				if (g_map[i][j] == LOCATION) 
				{
					x = i;
					y = j;
					g_map[i][j] = BLACK;
				}
			}
		}
		printf("%d\n", dfs(g_map, m + 2, n + 2, x, y));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41645983/article/details/88689383