HDU-1159-Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

分析:求公共最长子序列,对第一个例子来说就是:(“abcb”)所以为4。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1005
char s1[maxn],s2[maxn];
int dp[maxn][maxn];
int main()
{
	while(~scanf("%s",s1))
	{
		memset(dp,0,sizeof(dp));
		scanf("%s",s2);
		int len1 = strlen(s1);
		int len2 = strlen(s2);
		for(int i = 0; i < len1; i ++)
			for(int j = 0; j < len2; j ++)
			{
				if(s1[i]==s2[j])
					dp[i+1][j+1] = dp[i][j] + 1;
				else
					dp[i+1][j+1] = max(dp[i+1][j],dp[i][j+1]);
			}
		printf("%d\n",dp[len1][len2]);
	}
 } 

猜你喜欢

转载自blog.csdn.net/qiulianshaonv_wjm/article/details/83794562