HDU1159:Common Subsequence(DP 最长子序列 LCS)

Common Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51479 Accepted Submission(s): 23706

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0

这题为求最长子序列的问题,最好手画张图。

下面附上ac代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <ctype.h>
#include <queue>
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;
typedef long long int ll;
string a,b;
int dp[1000][1000];
int main() {
    while(cin >> a >> b) {
        int la = a.size();
        int lb = b.size();
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < la; i++) {
            for(int j = 0; j < lb; j++) {
                if(a[i] == b[j]) {
                    dp[i+1][j+1] = dp[i][j] + 1; //画图即可看出
                }
                else {
                    dp[i+1][j+1] = std::max(dp[i][j+1],dp[i+1][j]);
                }
            }
        }
        cout << dp[la][lb] << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43555854/article/details/86624652