hdu1159 Common Subsequence

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0

模板题最长公共子序列,直接套用就ok

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[505],s2[505];
int k1,k2,i,j,k,c[505][505];
void LCS()
{
	for(i=1;i<=k1;i++)
	{
		for(j=1;j<=k2;j++)
		{
			if(s1[i-1]==s2[j-1])
			c[i][j]=c[i-1][j-1]+1;
			else
			c[i][j]=max(c[i-1][j],c[i][j-1]); 
		}
	}
}
int main()
{
	while(cin>>s1>>s2)
	{
		memset(c,0,sizeof(c));
		k1=strlen(s1);
		k2=strlen(s2);
		for(i=0;i<=k1;i++)
		c[i][0]=0;
		for(i=0;i<=k2;i++)
		c[0][i]=0;
		LCS();
		printf("%d\n",c[k1][k2]);		
	}
}

猜你喜欢

转载自blog.csdn.net/lemon1090/article/details/89423844