HDU-1159 Common Subsequence 最长公共子序列~~

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46514    Accepted Submission(s): 21357


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
 
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
 
  
4 2 0
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1087  1176  2084  1257  1421 
        


        其实就是让你找到两串的最长公共子序列~~子序列与子串不同~子序列两两之间可以不临近~但是要符合总的原字符串下的前后关系~

              

       我们建造一个二维数组c~他的c[i][j]用来代表着第一个子串取到i个字符,第二个子串取到第j个字符时~~他们的最长公共子序列是多少~~这样的话我们便可以得到上方的状态转移方程~~::

        1.假设子串分别为m,n,那么当m[i]==n[j]的时候~这时候的最长上升子序列肯定为~不算i与j这两位的最长公共子序列:c[i-1][j-1]的值加上1(就是这一相同位i j)~~;

        2.假设此时m[i]!=n[j]的时候~~那么此时的最长公共子序列便是不算这个i位的c[i-1][j],以及不算这个j位的c[i][j-1]中的值大的那一个了~~想一想其实很好理解的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
using namespace std;
int c[1005][1005];
int main()
{
    string m,n;
    while(cin>>m>>n)
    {
        memset(c,0,sizeof(c));
        int lenn=n.length();
        int lenm=m.length();
        for(int s=0;s<lenn;s++)
        {
            for(int w=0;w<lenm;w++)
            {
                int a=s+1,b=w+1;
                if(n[s]==m[w])
                {
                    c[a][b]=c[a-1][b-1]+1;
                }
                else
                {
                    c[a][b]=max(c[a][b-1],c[a-1][b]);
                }
            }
        }
        cout<<c[lenn][lenm]<<endl;
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/80527001