HDU1159 Common Subsequence【最长公共子序列】

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49520    Accepted Submission(s): 22806


 

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

问题链接:HDU1159 Common Subsequence

问题描述:求两个字符串的最长公共子序列

解题思路:最长公共子序列的模板题

AC的C++代码:

扫描二维码关注公众号,回复: 3997972 查看本文章
#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>

using namespace std;
const int N=1005;
int dp[N][N];

int LCS(string a,string b)
{
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=a.length();i++)
	  for(int j=1;j<=b.length();j++)
	    if(a[i-1]==b[j-1])
	      dp[i][j]=dp[i-1][j-1]+1;
	    else
	      dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
	return dp[a.length()][b.length()];
}

int main()
{
	string a,b;
	while(cin>>a>>b)
	  cout<<LCS(a,b)<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83894630