HDU1159-Common Subsequence(LIS+滚动数组)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Input
abcfbc abfcab
programming contest
abcd mnp
Output
4
2
0
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

分析:

题意:
输入两个字符串str1和str2,求两个字符串的最长公共子串的长度?注意,这最长公共子串中的字符可能不是连续的!!!

解析:
最长公共子序列,这是一个动态规划的经典问题,我们用dp[i][j]表示str1的前i个字符组成的字符串与str2的前j个字符组成的字符串的最长公共子序列的长度。

根据题意,我们写出状态转移方程:
(1)如果str1[i]==str2[j]:
dp[i][j]=dp[i-1][j-1]+1;
(2)如果str1[i]!=str2[j]:
dp[i][j]=max(dp[i][j-1],dp[i-1][j]);

结合状态转移方程以及下面这个图形,我们就可以更好的理解:

在这里插入图片描述

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

int dp[2][1005];

int main()
{
	string str1,str2;
	while(cin>>str1>>str2)
	{
		int len1=str1.length(),len2=str2.length();
		for(int i=1;i<=len1;i++)
		{
			for(int j=1;j<=len2;j++)
			{
				if(str1[i-1]==str2[j-1])
	            {
	                dp[i%2][j]=dp[(i-1)%2][j-1]+1;
	            }
	            else
	            {
	                dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
	            }
			}
		}
		printf("%d\n",dp[len1%2][len2]);
		memset(dp,0,sizeof(dp));
	}
	return 0;
 } 
发布了64 篇原创文章 · 获赞 17 · 访问量 872

猜你喜欢

转载自blog.csdn.net/weixin_43357583/article/details/105396454