hdu 1159 Common Subsequence 【最长公共子序列】【dp】

题目中文意思就是                 【求两个字符串最长公共子序列】

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

【思考】如何处理i,j-1后下标越界,变成-1;   处理方法全加1,代码中有解释

扫描二维码关注公众号,回复: 2717291 查看本文章
#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;

int main() {
	int s[1001][1001];
	memset(s,0,sizeof(s));
	char a[1010],b[1010];
	char x;
	int i=1,j=1;
	while(scanf("%s %s",a,b)!=EOF) {
		int a_len=strlen(a);
		int b_len=strlen(b);
		memset(s,0,sizeof(s));
		int t=0,p=0;
		for(int i=0; i<a_len; ++i) {//i,j从0开始,按照之前的dp[i][j]=dp[i-1][j-1] 
			for(int j=0; j<b_len; ++j) {//i-1会<0 
				if(a[i]==b[j]) {//
					s[i+1][j+1]=s[i][j]+1;//i,j同时+1 ,则输出的下标为s[a_len][b_len] 
				} 
				else {
					s[i+1][j+1]=max(s[i][j+1],s[i+1][j]);
				}

			}
		}
		printf("%d\n",s[a_len][b_len]);
	}

猜你喜欢

转载自blog.csdn.net/weixin_42382758/article/details/81544268