【HDU1159】Common Subsequence(LCS/DP)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

题目大意:给出两个序列,请找出这两个序列的最大公共子序列来输出它的个数。

分析:

这里写图片描述

如上图,就可以退出状态方程:当str1[i]==str2[j]时,计数的dp[i][j]就+1.

当两个不等于时,就找他左边或上边最大的 dp[i][j]=max(dp[i-1][j],dp[i][j-1])。

记得先处理第一行和第一列就可以开始递推下去了

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e3+5;

char str1[maxn];
char str2[maxn];
int dp[maxn][maxn];

int main(){
    while(~scanf("%s%s",&str1,&str2)){
        memset(dp,0,sizeof(dp));
        int n = strlen(str1);
        int m = strlen(str2);
        if( str1[0]==str2[0] ){
            dp[0][0]=1;
        }
        for( int i=1 ; i<n ; i++ ){
            if(str1[i]==str2[0])
            dp[i][0] += 1;
            else
            dp[i][0]=max(dp[i-1][0],0);
        }
        for( int i=1 ; i<m ; i++ ){
            if(str1[0]==str2[i])
            dp[0][i] += 1;
            else
            dp[0][i]=max(dp[0][i-1],0);
        }
        for( int i=1 ; i<n ; i++ ){
            for( int j=1 ; j<m ; j++ ){
                if(str1[i]==str2[j]){
                    dp[i][j]=dp[i-1][j-1]+1 ;
                }
                else{
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        /*for( int i=0 ; i<n ; i++ ){
            for( int j=0 ; j<m ; j++ ){
                printf("%d",dp[i][j]);
            }
            cout<<endl;
        }*/
        printf("%d\n",dp[n-1][m-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/52027034