暑假训练 Common Subsequence HDU - 1159 dp求LCS

题目描述:
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0
code:

#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
#include<string.h>
using namespace std;

string a, b;
const int maxn = 1005;
int dp[maxn][maxn];
int main()
{
    while(cin>>a>>b)
    {
        int m = a.size();
        int n = b.size();
        if(m == 0 || n == 0){cout<<0<<endl;continue;}
        memset(dp, 0, sizeof dp);
        for(int i = 1; i <= m; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(a[i-1] == b[j-1])dp[i][j] = dp[i-1][j-1] + 1;
                else dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
            }
        }
        cout<<dp[m][n]<<endl;
    }
    return 0;
}

dp的一个比较重要的应用,看数据结构课上也学过,然而已经忘了,又去重温了这个算法。还有一个讲解的很详细的博客:LCS

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82958324
今日推荐