HDU 1159 Common Subsequence(dp基础:最长公共子序列)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46318    Accepted Submission(s): 21236


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
 
  
abcfbc abfcab
programming contest 
abcd mnp
 

Sample Output
 
  
4
2
0

//输出是abca   
#include<stdio.h>  
#include<string.h>  
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  
int dp[1005][1005];  
int main(){  
    string a,b,c;
	while(cin>>a>>b)
	{
		for(int i=0;i<=a.length();i++)
		{  
	        for(int j=0;j<=b.length();j++)
			{  
	            if(a[i]==b[j])  
	                dp[i+1][j+1]=dp[i][j]+1;  
	            else dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);  
	        }  
    	}    
    	cout<<dp[a.length()][b.length()]<<endl; 
	}  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80375510