hdoj1159:Common Subsequence(dp基础题-最长公共子序列LCS)

版权声明:转载请注明出处哦~ https://blog.csdn.net/Cassie_zkq/article/details/82918074

目录

Common Subsequence

题目解释:

解题思路:

ac代码:


Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 26   Accepted Submission(s) : 15

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

题目解释:


求两个字符串的最长公共子序列的长度(子序列可以不连续)

解题思路:


状态转移方程:

if (a[i]==b[j])

dp[i][j]=dp[i-1][j-1]+1;

else

dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

ac代码:


注意字符串的读取语句

#include <iostream>
 #include <cstring>
#define maxn 1005
using namespace std;
int main()
{
    int dp[maxn][maxn];//dp[i][j]表示a的第i个字符和b的第j个字符的LCS
    char a[maxn],b[maxn];
    while(cin>>a+1>>b+1)
    {
        int lena=strlen(a+1),lenb=strlen(b+1);
        int i,j;//i指向a,j指向b
        for(i=0;i<=lena;i++)//i从0开始,因为下面有i-1
            dp[i][0]=0;
        for(j=0;j<=lenb;j++)
            dp[0][j]=0;
        for(i=1;i<=lena;i++)
        {
           for(j=1;j<=lenb;j++)
          {
            if(a[i]==b[j])
                dp[i][j]=dp[i-1][j-1]+1;
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
          }
        }
        printf("%d\n",dp[lena][lenb]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Cassie_zkq/article/details/82918074