PAT:A1069 The Black Hole of Numbers

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82110771

PAT:A1069 The Black Hole of Numbers

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

bool cmp(int a, int b) {
	return a > b;
}

void to_array(int n, int a[]) {
	for(int i = 0; i < 4; i++) {
		a[i] = n % 10;
		n = n / 10;
	}
}

int to_number(int num[]) {
	int sum = 0;
	for(int i = 0; i < 4; i++) {
		sum = sum*10 + num[i];
	}
	return sum;
}

int main() {
	int a[5], min, max, n;
	scanf("%d", &n);
	while(true) {
		to_array(n, a);
		sort(a, a+4);
		min = to_number(a);
		sort(a, a+4, cmp);
		max = to_number(a);
		n = max - min;
		printf("%04d - %04d = %04d\n",max, min, n);
		if(n == 0 || n == 6174) break;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82110771
今日推荐