【PAT甲级】1069 The Black Hole of Numbers (20)(黑洞数)

题目链接

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089\ 9810 - 0189 = 9621\ 9621 - 1269 = 8352\ 8532 - 2358 = 6174\ 7641 - 1467 = 6174\ ... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N

  • N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

思路:四位的黑洞数是6174.  注意最少有一次输出,即n=0的时候

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define DBGS() cout<<"START\n"
#define DBGE() cout<<"END\n"
const int N = 256+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;

int a[5];
int convert(int star,int end,int flag) {
    int res=0;
    if(flag) {
        for(int i=star; i<end; i++)
            res=res*10+a[i];
    } else {
        for(int i=end-1; i>=star; i--)
            res=res*10+a[i];
    }
    return res;
}
int main() {
    int n;
    scanf("%d",&n);
    do {
        for(int i=0; i<4; i++) {
            a[i]=n%10;
            n/=10;
        }
        sort(a,a+4);
        int maxx=convert(0,4,0);
        int minx=convert(0,4,1);
        n=maxx-minx;
        printf("%04d - %04d = %04d\n",maxx,minx,n);
    } while(n!=6174&&n!=0);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81514562
今日推荐