PAT-1069 The Black Hole of Numbers

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82082791

1069 The Black Hole of Numbers(20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

    注意输入6174时的输出。

#include<stdio.h>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;

int string2int(string s){
	int a;
	stringstream stream(s);
	stream >> a;
	return a;
}
string int2string(int a){
	stringstream stream;
	stream << a;
	string s=stream.str();
	while(s.size()<4){
		s.insert(s.begin(),'0');
	}
	return s;
}
bool cmp(char c1,char c2){
	return c1>c2;
}
int main(){
	int n;
	scanf("%d",&n);

	do{
		string s1=int2string(n);
		string s2=s1;
		sort(s1.begin(),s1.end());
		sort(s2.begin(),s2.end(),cmp);
		if(s1==s2){
			printf("%04d - %04d = 0000",n,n);
			return 0;
		}
		int n1=string2int(s1);
		int n2=string2int(s2);
		n=n2-n1;
		printf("%04d - %04d = %04d\n",n2,n1,n);

	}while(n!=6174);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82082791
今日推荐