PAT A 1069 The Black Hole of Numbers

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089\ 9810 - 0189 = 9621\ 9621 - 1269 = 8352\ 8532 - 2358 = 6174\ 7641 - 1467 = 6174\ … …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N

N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

就数字转换为数组,排序后再转换为数字,循环。

#include<cstdio>
#include<algorithm>
using namespace std;

bool cmp(int a, int b) {
    return a > b;
}

void to_array(int a, int b[]) {
    for (int i = 0; i < 4; i++) {
        b[i] = a % 10;
        a = a / 10;
    }
}

int to_number(int a[]) {
    int ans = 0;
    for (int i = 0; i <4; i++) {
        ans = ans * 10 + a[i];
    }
    return ans;
}

int main() {
    int n, num[5];
    int Max, Min;
    scanf("%d", &n);
    to_array(n, num);
    while (1) {
        sort(num, num + 4);
        Min = to_number(num);
        sort(num, num + 4, cmp);
        Max = to_number(num);
        printf("%04d - %04d = %04d\n", Max, Min, Max - Min);
        to_array(Max - Min, num);
        if (Max - Min == 6174 || Max - Min == 0) break;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81055855
今日推荐