PAT (Advanced Level) Practice A1069 The Black Hole of Numbers (20 分)(C++)(甲级)(数字黑洞英文版)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86574460

1069 The Black Hole of Numbers (20 分)
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767
Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:

2222
Sample Output 2:

扫描二维码关注公众号,回复: 5024448 查看本文章

2222 - 2222 = 0000

//B1019 数字黑洞 英文版
//https://blog.csdn.net/m0_37454852/article/details/86574410
using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include <cmath>

int main()
{
	int num = 0, N[4] = {0};
	scanf("%d", &num);
	do
	{
        for(int i = 0; i < 4; i++)//拆分
        {
            N[i] = num % 10;
            num /= 10;
        }
		sort(N, N+4);//排序
		int minuend = N[3] * 1000 + N[2] * 100 + N[1] * 10 + N[0];//减数、被减数
		int subtrahend = N[0] * 1000 + N[1] * 100 + N[2] * 10 + N[3];
		num = minuend - subtrahend;//差
		printf("%04d - %04d = %04d\n", minuend, subtrahend, num);//输出
	} while (num && num != 6174);//结果为0或6174则停止
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86574460
今日推荐