1069 The Black Hole of Numbers(20 分)

1069 The Black Hole of Numbers(20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

 解题思路:用string来做比较方便,排序的话直接用sort(s.begin(),s.end(),cmp),字符直接比较,我居然还把它转化成数字再来比较,后面就直接字符比较,然后计算差的时候直接把它们转成数字,这里有个注意的地方,这题还算有点坑,就是它输入的不一定是4位数,还要自己再insert‘0’。

#include<bits/stdc++.h>
using namespace std;
bool cmp(char a,char b) 
{
	return a>b;
}
int main(void)
{
	string s;
	cin>>s;
	s.insert(0,4-s.size(),'0');
	do{
		string a=s,b=s;
		sort(a.begin(),a.end(),cmp);
		sort(b.begin(),b.end());
		int diff=stoi(a)-stoi(b);
		s=to_string(diff);
		s.insert(0,4-s.size(),'0');
		cout<<a<<" - "<<b<<" = "<<s<<endl;
	}while(s!="6174"&&s!="0000");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82261213
今日推荐