1069 The Black Hole of Numbers (20 分)

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int s1,s2;

void turn(int n)
{
    s1 = s2 = 0;
    int a[4];
    int i = 0;
    while(i<4){
        a[i++] = n%10;
        n/=10;
    }
    sort(a,a+4);
    i = 4;
    while(i--){
        s1 = s1*10 + a[i];
    }
    i = 0;
    while(i<4){
        s2 = s2*10 + a[i++];
    }
}

int main()
{
    int n;
    cin >> n;
    while(1){
        turn(n);
        n = s1-s2;
        printf("%04d - %04d = %04d\n",s1,s2,n);
        if(n==6174||n==0) break;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/89042601
今日推荐