1069 The Black Hole of Numbers

1069 The Black Hole of Numbers
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10
​4
​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

参考代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
bool cmp(int a,int b) {
	return a > b;
}
using namespace std;
vector<int>v;
int tonum() {
	int num = 0;
	for (int i = 0; i < 4; i++)
		num = num * 10 + v[i];
	return num;
}
int main(){
	int n, res, a, b;
	string s;
	cin >> n;
	res = n;
	if (n % 1111 == 0)
		printf("%04d - %04d = %04d", n, n, 0);
	else {
		do {
			v.clear();
			do {
				v.push_back(res % 10);
				res /= 10;
			} while (res != 0);
			while (v.size()!=4){ v.push_back(0); }
			sort(v.begin(), v.end(),cmp);
			a = tonum();
			sort(v.begin(), v.end());
			b = tonum();
			res = a - b;
			printf("%04d - %04d = %04d\n", a, b, a - b);
		
		} while (res != 6174);
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82926148
今日推荐