PAT甲级 1069 The Black Hole of Numbers (20 分)

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

分析:有一个测试用例注意点,如果当输入N值为6174的时候,依旧要进行下面的步骤,直到差值为6174才可以~所以用do while语句,无论是什么值总是要执行一遍while语句,直到遇到差值是0000或6174~

s.insert(0, 4 – s.length(), ‘0’);用来给不足4位的时候前面补0~

#include <iostream>
#include <algorithm>
using namespace std;

int cmp(char a,char b){
    return a > b;
}

int main()
{
    string str,temp;
    cin>>str;
    int a,b;

    do{//第一次输入若是6174也要进行操作
        //输字可能不足4位,需补齐后排序
        str.insert(0,4-str.length(),'0');

        sort(str.begin(),str.end(),cmp);
        temp = str;
        sort(temp.begin(),temp.end());
        a = stoi(str);
        b = stoi(temp);
        if(a-b == 0){
            printf("%04d - %04d = %04d\n",a,a,0);
            return 0;
        }else{
            printf("%04d - %04d = %04d\n",a,b,a-b);
            str = to_string(a-b);
        }
    }while(str != "6174");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82946383
今日推荐