PAT 1069 The Black Hole of Numbers (20 分)

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we’ll get:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.


Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0, 1 0 4 10^4 ).


Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000




解析

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
	int num, num1, num2;
	scanf("%d", &num);
	do {
		vector<int> digit;
		for (int i = 0; i < 4; i++) {
			digit.push_back(num % 10);
			num /= 10;
		}
		sort(digit.begin(), digit.end());
		num1 = digit[0] + digit[1] * 10 + digit[2] * 100 + digit[3] * 1000;
		num2 = digit[3] + digit[2] * 10 + digit[1] * 100 + digit[0] * 1000;
		num = num1 - num2;
		printf("%04d - %04d = %04d\n", num1, num2, num);
	} while (num !=0 && num!= 6174);

}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84452463
今日推荐