1069 The Black Hole of Numbers(20 分)(cj)

1069 The Black Hole of Numbers(20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

思路 俩个坑点 一个是 输入的时候不是4位数字 ,  另一个是 6174 也需要输出 一行 不能无结果。

code

#pragma warning(disable:4996)
#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
bool cmp(const int& a, const int& b) {
	return a > b;
}
int covert(string& s) {
	int sum = 0;
	for (int i = 0; i < 4; ++i) {
		sum *= 10;
		sum += (s[i] - '0');
	}
	return sum;
}
string decover(int x) {
	string res;	
	for (int i = 0; i < 4; ++i) {
		res += (x % 10 + '0');
		x /= 10;
	}
	string dres(res.rbegin(), res.rend());
	return dres;
}
int main(){
		int n;
		cin >> n;
		string s;
		s = decover(n);
		if (s[0] == s[1] && s[1] == s[2] && s[2] == s[3]) {
			cout << s << " - " << s << " = " << "0000" << endl;
		}
		else {
			do{
				sort(s.begin(), s.end(), cmp);
				cout << s << " - ";
				int a = covert(s);
				sort(s.begin(), s.end());
				cout << s << " = ";
				int b = covert(s);
				int dif = a - b;
				s = decover(dif);
				cout << s << endl;
			} while (s != "6174");
		}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82259201
今日推荐