[PAT甲级] 1069 The Black Hole of Numbers (20)

题目:

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089\ 9810 - 0189 = 9621\ 9621 - 1269 = 8352\ 8532 - 2358 = 6174\ 7641 - 1467 = 6174\ … …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000


题目简介:读取一个整数(0, 10000), 若不是4位数,在前面补0。然后每一位从大到小排列减去每一位从小到大排列,产生新的4位数,重复此过程直至最后的四位数为6174或0000。

#include <iostream>
#include <iomanip>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
bool compare(char a, char b){
    return a > b;
}
int main() {
    int N, M, result;
    char c[4];
    scanf("%d", &result);
    do{
        sprintf(c, "%04d", result);
        sort(c, c + 4, compare);
        N = atoi(c);
        sort(c, c + 4);
        M = atoi(c);
        result = N - M;
        printf("%04d - %04d = %04d\n", N, M, result);
    }while(result != 6174 && result != 0);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Sternley/article/details/81232117
今日推荐