2---- Red and Black (dfs--(深搜))

Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
0 0
Sample Output
59
6

#include<stdio.h>
using namespace std;
char field[105][105];
int ss[4][2]={-1,0,0,1,1,0,0,-1};
int m,n,k;//m为行,n为列
void dfs(int x,int y)
{
    field[x][y]='#';
    for(int i=0;i<4;i++)
    {
       int nx=x+ss[i][0],ny=y+ss[i][1];
       if(nx>=1&&nx<=m&&ny>=1&&ny<=n&&field[nx][ny]=='.')
      {
          dfs(nx,ny);
          k++;
      }
    }
    return ;
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0) break;
     k=1;
    for(int i=1;i<=m;i++)
    {
        scanf("%s",field[i]+1);
    }
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
    {
        if(field[i][j]=='@')
          {
              dfs(i,j);
          }
    }
    printf("%d\n",k);
}
return 0;
}

与第一个博客内容差不多,上一个题是周围8个块进行搜索,此题是对上下左右四个方向进行搜索,
题都比较简单,多看看,就能理解

猜你喜欢

转载自blog.csdn.net/Nacht_one/article/details/81741707