【深搜】Red and Black

描述

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

输出

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

样例输入

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

样例输出

45
59
6
13

分析:深搜统计
代码:
#include<bits/stdc++.h>
using namespace std;
int W,H;
string s[21];
int DFS(int x,int y)
{
if (x<0||x>H-1||y<0||y>W-1)
{
return 0;
}
if (s[x][y]’#’) return 0;
else
{
s[x][y]=’#’;
return 1+DFS(x-1,y)+DFS(x+1,y)+DFS(x,y-1)+DFS(x,y+1);
}
}
int main()
{
while(cin>>W>>H)
{
if (W
0&&H0) break;
int x,y;
bool f=0;
for (int i=0;i<H;i++)
{
cin>>s[i];
for (int j=0;j<W;j++)
{
if (f) break;
if (!f&&s[i][j]
’@’)
{
x=i;
y=j;
f=1;
}
}
}
//cout<<x<<’ '<<y<<endl;
int ans=DFS(x,y);
cout<<ans<<endl;
}
return 0;
}

发布了40 篇原创文章 · 获赞 0 · 访问量 670

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/103652771