hdu1159Common Subsequence——动态规划(最长公共子序列)

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
Sample Output
4 2 0
 
现附上AC代码:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1000+10;
int s[maxn][maxn];
char str1[maxn],str2[maxn];

void solve()
{
memset(s,0,sizeof(s));
while(~scanf("%s%s",str1+1,str2+1))
{
int s1=strlen(str1+1),s2=strlen(str2+1);
for(int i=1;i<=s1;i++)
{
for(int j=1;j<=s2;j++)
{
if(str1[i]==str2[j]) s[i][j]=s[i-1][j-1]+1;
else s[i][j]=max(s[i-1][j],s[i][j-1]);
}
}
cout<<s[s1][s2]<<endl;
}
}
int main()
{
solve();
return 0;
}

在做动态规划问题时,有不少情况都是需要申请一个二维数组存储每个状态。例如这道题中s[i][j]存储的是第一个字符串前i个字符与第二个字符串前j个字符的最长公共子序列,而这也是动态规划的主要思想,多阶段决策。有时二维数组也可用一维数组进行代替,使用滚动数组,但这样就不能直到最有方案的具体步骤。

做动态规划重要的是找好二维数组,明确两个下标的具体意义,并找到递推公式,那么这道题就基本可以完成了。

猜你喜欢

转载自www.cnblogs.com/sunjianzhao/p/11373156.html