Common Subsequence HDU - 1159 ( 最长公共子序列+动态规划 )

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/SEVENY_/article/details/83790397

Common Subsequence

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

题意:

给出两个序列,然后找出来他们的最长的公共子序列。

例如:序列a:abcfbc      序列b:abfcab

 

a

b

c

f

b

c

a

1

1

1

1

1

1

b

1

2

2

2

2

2

f

1

2

2

3

3

3

c

1

2

3

3

 3

4

a

1

2

3

3

3

4

b

1

2

3

3

4

4


 

            当a[i]==b[j]时候,dp[i][j]=dp[i-1][j-1]+1;

            当a[i]!=b[j]时候,dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int dp[1007][1007];
int main()
{
	char a[1007],b[1007];
	int lena,lenb;
	while(scanf("%s %s",a,b)!=EOF)
	{
		lena=strlen(a);
		lenb=strlen(b);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=lena;i++)
		{
			for(int j=1;j<=lenb;j++)
			{
				if(a[i-1]==b[j-1])
				{
					dp[i][j]=dp[i-1][j-1]+1;
				}
				else
				{
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
				} 
			}
		}
		printf("%d\n",dp[lena][lenb]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SEVENY_/article/details/83790397